<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="News,Brandon, Crash, Brandon First Responders, Brandon Fire Department, Douglas County Sheriff&#039;s Office, Life Link III, North Ambulance" />
<meta property="news_keywords" content="News,Brandon, Crash, Brandon First Responders, Brandon Fire Department, Douglas County Sheriff&#039;s Office, Life Link III, North Ambulance" />
<meta property="author" content="Beth Leipholtz" />
<meta property="description" content="Emergency responders were called to a crash near Brandon on Wednesday, Sept. 6.Shortly before 6 p.m., a two-vehicle crash was reported at the intersection of..." />
<meta property="twitter:site" content="echopress" />
<meta property="og:description" content="Emergency responders were called to a crash near Brandon on Wednesday, Sept. 6.Shortly before 6 p.m., a two-vehicle crash was reported at the intersection of Aldrich Road NW and County Road 109, east of Brandon.According to scanner traffic, there were five people injured at the scene, including two children.Scanner..." />
<meta property="article:modified_time" content="2017-09-07T00:15:50-05:00" />
<meta property="image:title" content="One of the drivers in a two-vehicle crash near Brandon was airlifted by LifeLink III. The crash happened Wednesday evening at the intersection of County Road 109 and Lake Aldrich Court. (Celeste Edenloff | Echo Press)" />
<meta property="image:alt" content="One of the drivers in a two-vehicle crash near Brandon was airlifted by LifeLink III. The crash happened Wednesday evening at the intersection of County Road 109 and Aldrich Road. (Celeste Edenloff | Echo Press)" />
<meta property="twitter:description" content="Emergency responders were called to a crash near Brandon on Wednesday, Sept. 6.Shortly before 6 p.m., a two-vehicle crash was reported at the intersection of Aldrich Road NW and County Road 109, east of Brandon.According to scanner traffic, there were five people injured at the scene, including two children.Scanner..." />
<meta property="article:tag" content="News,Brandon, Crash, Brandon First Responders, Brandon Fire Department, Douglas County Sheriff&#039;s Office, Life Link III, North Ambulance" />
<meta property="article:published_time" content="2017-09-07T00:15:50-05:00" />
<meta property="article:publisher" content="https://www.facebook.com/echopress" />
<meta property="twitter:url" content="http://www.echopress.com/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured" />
<meta property="twitter:image" content="http://www.echopress.com/sites/default/files/styles/16x9_430/public/0B19D_4vNjobwM1RIZWZXdVd0R0U.jpg?itok=4PIj3hAX" />
<meta property="og:site_name" content="Echo Press" />
<meta property="og:image:height" content="698" />
<meta property="og:image:width" content="1240" />
<meta property="twitter:title" content="Updated: One airlifted after crash near Brandon, five others..." />
<meta property="og:title" content="Updated: One airlifted after crash near Brandon, five others..." />
<meta property="og:image" content="http://www.echopress.com/sites/default/files/styles/16x9_1240/public/0B19D_4vNjobwM1RIZWZXdVd0R0U.jpg?itok=0GMdmuTW" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="664199946964112" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="og:url" content="http://www.echopress.com/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><link rel="apple-touch-icon" href="http://www.echopress.com/sites/all/themes/echopress_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.echopress.com/sites/all/themes/echopress_theme/favicon.ico" type="image/x-icon" />
<link rel="shortlink" href="/node/4323823" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="amphtml" href="http://www.echopress.com/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured?amp" />
<link rel="canonical" href="/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>Updated: One airlifted after crash near Brandon, five others injured | Echo Press</title>
    <link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_dn1Z7ijuixoG-wMmyYi-2wgXq6gNxLsgC7vdi2dJMWs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/fcc_basetheme/css/article-slider.css?ovvuin" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?ovvuin" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/echopress_theme/css/global-no-mqs.css?ovvuin" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/echopress_theme/css/global.css?ovvuin" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_F77Wk3ElhI0IWc9W9h5jNjw2XWOBI81sjCu16e_P21s.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-6', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?ovvuin"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?ovvuin"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

       var OX_dfp_options = {prefetch: true};
       if (jQuery(window).width() >= 728) {
         var OX_dfp_ads = [
            ['/7021/fcc.forum/echopress', ['300x250', '120x600', '160x600', '300x600'], 'article-sidebar-ad'],
            ['/7021/fcc.forum/echopress', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'top-leaderboard-ad'],
            ['/7021/fcc.forum/echopress', ['728x90', '320,100', '320,50', '300,50'], 'mid-leaderboard-ad'],
            ['/7021/fcc.forum/echopress', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'bottom-leaderboard-ad'],
            ['/7021/fcc.forum/echopress', ['300x250', '320x100', '320x50', '300x50'], 'photo-gallery-ad'],
          ];
        } else {
          var OX_dfp_ads = [
            ['/7021/fcc.forum/echopress', ['300x100', '320x50', '300x50'], 'first-mobile-ad'],
            ['/7021/fcc.forum/echopress', ['320x100', '320x50', '300x50'], 'second-mobile-ad'],
            ['/7021/fcc.forum/echopress', ['320x100', '320x50', '300x50'], 'third-mobile-ad'],
            ['/7021/fcc.forum/echopress', ['320x100', '320x50', '300x50'], 'fourth-mobile-ad'],
          ];
        }
//--><!]]>
</script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-EchoPress"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//biddr.brealtime.com/28228967-1007.js"></script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_Y1rdwRgUs4JbtR_PFE950_FKiFhHKa6FjSWv_MUBj8g.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4323823 node-type-article domain-www-echopress-com context-news"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <!--<li class="last">
            <a href="/register" title="Register">Register</a>
          </li>-->
        </ul>
                </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="Classifieds">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="Marketplace">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Echo Press"><img src="http://www.echopress.com/sites/all/themes/echopress_theme/logo.png" alt="Echo Press" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Echo Press</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/echopress_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4323860-b-e-board-will-rethink-school-plans'>B-E board will rethink school plans</a></li><li><a href='/news/4323836-mom-two-suspects-were-best-friends'>Mom: Two suspects were ‘best friends’</a></li><li><a href='/news/4323835-mom-two-suspects-were-best-friends'>Mom: Two suspects were ‘best friends’</a></li><li><a href='/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured'>Updated: One airlifted after crash near Brandon, five others injured</a></li><li><a href='/news/4323615-update-teen-girl-swam-escape-captors-three-men-arrested'>Update: Teen girl swam to escape captors; three men arrested</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/crime" target="_self">crime</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/state" target="_self">state</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/chargers/4323567-chargers-golf-tournament-set-sept-16'>Chargers Golf Tournament set for Sept. 16</a></li><li><a href='/sports/lakers/4323566-volleyball-lakers-fall-five-sets-bold'>Volleyball: Lakers fall in five sets to BOLD</a></li><li><a href='/sports/knights/4323560-volleyball-wca-falls-three-new-york-mills'>Volleyball: WCA falls in three at New York Mills</a></li><li><a href='/sports/knights/4323559-volleyball-wca-falls-three-new-york-mills'>Volleyball: WCA falls in three at New York Mills</a></li><li><a href='/sports/cardinals/4323550-tennis-cards-drop-4-3-match-willmar'>Tennis: Cards drop 4-3 match to Willmar</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/cardinals" target="_self">cardinals</a></li><li><a href="/sports/chargers" target="_self">chargers</a></li><li><a href="/sports/silverstreaks" target="_self">silverstreaks</a></li><li><a href="/sports/arrows" target="_self">arrows</a></li><li><a href="/sports/blizzard" target="_self">blizzard</a></li><li><a href="/sports/area" target="_self">area</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/entertainment/4322422-american-pickers-visit-minnesota'>‘American Pickers’  to visit Minnesota</a></li><li><a href='/life/events/4321751-class-1947-celebrates-70th-reunion'>Class of 1947 celebrates 70th reunion</a></li><li><a href='/life/faith/4321774-faith-news-sept-10-busy-events'>Faith news: Sept. 10 busy with events</a></li><li><a href='/life/4321777-photo-week'>Photo of the Week</a></li><li><a href='/life/4321776-births'>Births</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/faith" target="_self">faith</a></li><li><a href="/life/features" target="_self">features</a></li><li><a href="/life/entertainment" target="_self">entertainment</a></li><li><a href="/life/events" target="_self">events</a></li><li><a href="/life/meeting-calendar" target="_self">meeting calendar</a></li><li><a href="/life/school" target="_self">school</a></li><li><a href="/life/senior" target="_self">senior</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/4323214-sjostrand-johnson'>Sjostrand-Johnson</a></li><li><a href='/milestones/4321126-wood-netter'>Wood-Netter</a></li><li><a href='/milestones/4321125-mccormack-suchy'>McCormack-Suchy</a></li><li><a href='/milestones/4319832-mccormack-suchy'>McCormack-Suchy</a></li><li><a href='/milestones/4317376-bob-and-marlys-ferris'>Bob and Marlys Ferris</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/births" target="_self">births</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/generations" target="_self">generations</a></li><li><a href="/milestones/special-occasions" target="_self">special occasions</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li></ul></div></div></li><li class='leaf'><a href="/outdoors" target="_self">outdoors</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/outdoors/4322643-mike-frisch-cover-more-water'>Mike Frisch: Cover more water</a></li><li><a href='/outdoors/4322644-whirlwind-win-alexandria-anglers-take-big-payday-first-pro-tournament'>A whirlwind of a win: Alexandria anglers take big payday in first pro tournament</a></li><li><a href='/outdoors/4322906-dnr-roadside-survey-pheasant-index-down-26-percent'>DNR roadside survey: Pheasant index down 26 percent</a></li><li><a href='/outdoors/4321488-local-du-banquet-set-sept-8'>Local DU banquet set for Sept. 8</a></li><li><a href='/outdoors/4321486-outdoor-briefs'>Outdoor briefs</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4323711-ralph-silverness-tillitt'>Ralph Silverness Tillitt</a></li><li><a href='/obituaries/4322776-carole-s-bakken-herzog'>Carole S. (Bakken) Herzog</a></li><li><a href='/obituaries/4322461-john-f-horn'>John F. Horn</a></li><li><a href='/obituaries/4321750-richard-raasch'>Richard Raasch</a></li><li><a href='/obituaries/4320269-larry-bakke'>Larry A. Bakke</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/columns/4322765-observations-archives-1967-major-league-scouts-eye-tournament'>Observations from the Archives: 1967: Major league scouts eye tournament </a></li><li><a href='/opinion/editorials/4322762-echo-press-editorial-whats-next-brandon-evansville'>Echo Press Editorial: What&#039;s next for Brandon-Evansville?</a></li><li><a href='/opinion/columns/4321766-its-our-turn-disaster-victims-need-tools-help-recover'>It&#039;s Our Turn: Disaster victims need tools, help to recover </a></li><li><a href='/opinion/commentaries/4321740-commentary-state-shouldnt-force-costly-upgrades-lake-winona'>Commentary: State shouldn&#039;t force costly upgrades on Lake Winona </a></li><li><a href='/opinion/editorials/4321735-thumbs-upthumbs-down-views-echo-press-editorial-board'>Thumbs Up/Thumbs Down: Views from the Echo Press Editorial Board</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/commentaries" target="_self">commentaries</a></li></ul></div></div></li><li class='leaf'><a href="/country" target="_self">country</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/country/agriculture/4322750-douglas-county-team-raising-turkey-destined-presidential-pardon'>Douglas County team raising turkey destined for presidential pardon</a></li><li><a href='/country/gardening/4314421-tomato-tasting-library'>Tomato tasting at the library</a></li><li><a href='/country/gardening/4313889-whats-wrong-my-tomato-plant'>What&#039;s wrong with my tomato plant?</a></li><li><a href='/country/4309581-theres-still-time-plant-veggies'>There&#039;s still time to plant veggies</a></li><li><a href='/country/agriculture/4306747-haying-and-grazing-ok-some-conservation-reserve-land'>Haying and grazing OK on some Conservation Reserve land</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/country/4-h" target="_self">4 h</a></li><li><a href="/country/agriculture" target="_self">agriculture</a></li><li><a href="/country/extension" target="_self">extension</a></li><li><a href="/country/farm" target="_self">farm</a></li><li><a href="/country/gardening" target="_self">gardening</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">business</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/business/4314257-glenwood-resort-receives-century-resort-designation'>Glenwood resort receives Century Resort designation</a></li><li><a href='/business/4314073-minnesota-adds-7700-jobs-july-unemployment-rate-unchanged'>Minnesota adds 7,700 jobs in July; unemployment rate unchanged</a></li><li><a href='/business/4311859-grant-helps-glenwood-downtown-facelift'>Grant helps Glenwood with downtown facelift</a></li><li><a href='/business/hires-and-promotions/4307214-leadership-change-runestone-museum'>Leadership change at Runestone Museum</a></li><li><a href='/4302980-schwans-announces-acquisitions-frozen-food-company-beefs-its-pizza-business'>Schwan&#039;s announces acquisitions as frozen food company beefs up its pizza business</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/business/awards" target="_self">awards</a></li><li><a href="/business/hires-and-promotions" target="_self">hires and promotions</a></li><li><a href="/business/new-business" target="_self">new business</a></li><li><a href="/business/street" target="_self">on the street</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-breaking-news block-fcc-breaking-news block-fcc-breaking-news-fcc-breaking-news odd block-without-title" id="block-fcc-breaking-news-fcc-breaking-news">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="breaking-alert alerts-intro"><a href="https://twitter.com/share" class="twitter-share-button" data-count="none" data-url="http://www.echopress.com/news/4323615-update-teen-girl-swam-escape-captors-three-men-arrested" data-text="Update: Teen girl swam to escape captors; three men arrested |" target="_blank">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?"http":"https";if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document, "script", "twitter-wjs");</script><a href="/news/4323615-update-teen-girl-swam-escape-captors-three-men-arrested"><h2>Update: Teen girl swam to escape captors; three men arrested</h2></a></div>    </div>
  </div>
</div><div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container even block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="News "> <meta itemprop='dateline' content="Alexandria,Minnesota 56308"> <meta itemprop='articleBody' content="&lt;p&gt;More information has been released about a two-vehicle crash near Brandon that injured six people Wednesday, including a driver who was airlifted to a hospital.&lt;p&gt;A preliminary investigation by the Douglas County Sheriff's Office indicates that a 1998 Chevy Lumina driven by Anthony Provost, 48, was westbound on Aldrich Road, and a 2002 Mercury Mountaineer driven by Michael Bakken, 34, was northbound on County Road 109. The intersection is marked with a yield sign for traffic on CR 109.&lt;p&gt;Authorities said Bakken failed to yield and collided with Provost's vehicle, striking the Lumina in the rear driver's side door. The Lumina entered the northwest ditch and overturned, coming to rest on its roof.&lt;p&gt;Two passengers in the Lumina, Shaynna Miller, 22, and Sophia Gragg, 10, were unrestrained and ejected from the car during the rollover, according to the sheriff's office.&lt;p&gt;Bakken's vehicle also entered the northwest ditch and overturned, coming to rest upright.&lt;p&gt;Miller was transported to Douglas County Hospital via North Ambulance. Provost was flown from the scene by Lifelink III. Their conditions are unknown.&lt;p&gt;Other passengers in the Lumina, Amy Whelchel, 29, and both Sophia Gragg and Emily Gragg, 5, were also transported by ambulance to the Douglas County Hospital. They have been treated and released.&lt;p&gt;Bakken was taken to the hospital via private party and his status is unknown.&lt;p&gt;The crash, which happened at about 5:40 p.m., remains under investigation. Assisting on scene was North Ambulance of Alexandria, Lifelink III Air Ambulance Service, Brandon Fire Dept and First Responders, Garfield Fire Dept and First Responders.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Updated: One airlifted after crash near Brandon, five others injured"> <meta itemprop='author' content="Beth Leipholtz"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.echopress.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-09-06T19:10:56"> <meta itemprop='dateModified' content="2017-09-07T00:15:50"> <link itemprop='mainEntityOfPage' content="node/4323823"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.echopress.com/sites/default/files/styles/square_300/public/0B19D_4vNjobwM1RIZWZXdVd0R0U.jpg?itok=gyGAHhO2"> <meta itemprop="width" content="3969"> <meta itemprop="height" content="2555"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Beth Leipholtz"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="Echo Press"</span> <meta itemprop="name" content="Beth Leipholtz"> <meta itemprop="homeLocation" content="Alexandria"> <div itemprop='contactPoint' itemscope itemtype='http://schema.org/ContactPoint'> <meta itemprop='faxNumber' content="(320) 763-3258"> <meta itemprop='contactType' content="customer support"> <meta itemprop='url' content="http://www.echopress.com"> <meta itemprop='telephone' content="(320) 763-1233"> <meta itemprop='email' content="eleipholtz@echopress.com"> </div> <meta itemprop='url' content="http://www.echopress.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Updated: One airlifted after crash near Brandon, five others injured "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Alexandria"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="225 7th Ave E<br /> P.O. Box 549"> <meta itemprop='postalCode' content="56308"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>Updated: One airlifted after crash near Brandon, five others injured</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/beth-leipholtz-0'>Beth Leipholtz</a></span>
  <span class='node-byline-time'> on Sep 6, 2017  at 7:10 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'>    <!-- Open Graph -->
    <meta property="og:video" content="http://content.jwplatform.com/videos/cQ5bTAGB.mp4" />
    <meta property="og:video:secure_url" content="https://content.jwplatform.com/videos/cQ5bTAGB.mp4" />
    <meta property="og:video:type" content="video/jwplayer"/>
    <meta property="og:video:release_date" content=""/>
    <meta property="og:video:tag" content=""/>
    <meta property="og:video:duration" content="24"/>
<span id="jwplayer-video-0">
            <!-- Schema.org -->
        <meta itemprop="name" content="Crash County Road 109" />
        <meta itemprop="description" content="" />
        <meta itemprop="thumbnailUrl" content="https://assets-jpcust.jwpsrv.com/thumbs/cQ5bTAGB-320.jpg" />
        <meta itemprop="contentUrl" content="https://content.jwplatform.com/videos/cQ5bTAGB.mp4" />
        <meta itemprop="uploadDate" content="1969-12-31 18:00:00"/>
        <script type="text/javascript">
        var playerInstance = jwplayer("jwplayer-video-0");
            playerInstance.setup({"playlist":"\/\/content.jwplatform.com\/feeds\/cQ5bTAGB.json","mediaid":"cQ5bTAGB","width":"100%","hlshtml":true,"androidhls":true,"aspectratio":"16:9","ga":{},"autostart":"true","advertising":{"client":"googima","schedule":{"adbreak1":{"offset":"pre","tag":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?iu=\/7021\/fcc.forum\/echopress&sz=640x480&cust_params=kw%3DBrandon%2CCrash%2CBrandon+First+Responders%2CBrandon+Fire+Department%2CDouglas+County+Sheriff%27s+Office%2CLife+Link+III%2CNorth+Ambulance%2CNews&ad_rule=0&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=%5BREFERRER_URL%5D&correlator=%5BTIMESTAMP%5D"},"adbreak2":{"offset":"post","tag":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?iu=\/7021\/fcc.forum\/echopress&sz=640x480&cust_params=kw%3DBrandon%2CCrash%2CBrandon+First+Responders%2CBrandon+Fire+Department%2CDouglas+County+Sheriff%27s+Office%2CLife+Link+III%2CNorth+Ambulance%2CNews&ad_rule=0&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=%5BREFERRER_URL%5D&correlator=%5BTIMESTAMP%5D"}}}});
            // Ad Error
            playerInstance.on('adError', function (event) {
                console.log('JWPlayer: Ad Error');
                console.log(event);
            });
    </script>
</span>
<style>
    .page-node div.article-slider div.individual-slide-1 {
        display: inline-block;
    }
    div.individual-slide { margin-top: -58px; }
</style>
<span class='slide-number'>1 / 3</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.echopress.com/sites/default/files/styles/16x9_620/public/0B19D_4vNjobwM1RIZWZXdVd0R0U.jpg?itok=gj4uGVA4' data-featherlight='http://www.echopress.com/sites/default/files/styles/full_1000/public/0B19D_4vNjobwM1RIZWZXdVd0R0U.jpg?itok=DtxEZo9a'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>One of the drivers in a two-vehicle crash near Brandon was airlifted by LifeLink III. The crash happened Wednesday evening at the intersection of County Road 109 and Aldrich Road. (Celeste Edenloff | Echo Press)</span><span class='slide-number'>2 / 3</span></div><div class='individual-slide individual-slide-3' style='position: relative;'><img class='node-image large' src='http://www.echopress.com/sites/default/files/styles/16x9_620/public/0B19D_4vNjobwUDRWQmhyN3lFbGs.jpg?itok=yxLC7kre' data-featherlight='http://www.echopress.com/sites/default/files/styles/full_1000/public/0B19D_4vNjobwUDRWQmhyN3lFbGs.jpg?itok=AfekxWCH'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Several law enforcement and emergency personnel responded to a two-vehicle crash at the intersection of County Road 109 and Aldrich Road east of Brandon. (Celeste Edenloff | Echo Press)</span><span class='slide-number'>3 / 3</span></div></div><div class='node-body'><p>More information has been released about a two-vehicle crash near Brandon that injured six people Wednesday, including a driver who was airlifted to a hospital.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_wiisnbtdswy757ucga6y5y6zkq' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>A preliminary investigation by the Douglas County Sheriff's Office indicates that a 1998 Chevy Lumina driven by Anthony Provost, 48, was westbound on Aldrich Road, and a 2002 Mercury Mountaineer driven by Michael Bakken, 34, was northbound on County Road 109. The intersection is marked with a yield sign for traffic on CR 109.</p><p>Authorities said Bakken failed to yield and collided with Provost's vehicle, striking the Lumina in the rear driver's side door. The Lumina entered the northwest ditch and overturned, coming to rest on its roof.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>Two passengers in the Lumina, Shaynna Miller, 22, and Sophia Gragg, 10, were unrestrained and ejected from the car during the rollover, according to the sheriff's office.</p><p>Bakken's vehicle also entered the northwest ditch and overturned, coming to rest upright.</p><p>Miller was transported to Douglas County Hospital via North Ambulance. Provost was flown from the scene by Lifelink III. Their conditions are unknown.</p><p>Other passengers in the Lumina, Amy Whelchel, 29, and both Sophia Gragg and Emily Gragg, 5, were also transported by ambulance to the Douglas County Hospital. They have been treated and released.</p><p>Bakken was taken to the hospital via private party and his status is unknown.</p><p>The crash, which happened at about 5:40 p.m., remains under investigation. Assisting on scene was North Ambulance of Alexandria, Lifelink III Air Ambulance Service, Brandon Fire Dept and First Responders, Garfield Fire Dept and First Responders.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div></div><div style='clear:both;'></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.echopress.com/taxonomy/term/1'>News</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/4292'>Brandon</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/1198'>Crash</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/399145'>Brandon First Responders</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/227308'>Brandon Fire Department</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/75217'>Douglas County Sheriff's Office</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/50758'>Life Link III</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/77684'>North Ambulance</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/beth-leipholtz-0'>Beth Leipholtz</a><img class='node-author-pic' src='http://www.echopress.com/sites/default/files/styles/vert_175/public/pictures/picture-352472-1503413688.jpg?itok=yghE5SRV'><div class='node-author-bio'><p>Beth is a reporter at the Echo Press. She graduated from the College of Saint Benedict in May 2015 with a degree in Communication and Hispanic Studies. Journalism has always been her passion, but she also enjoys blogging and graphic design. In her spare time, she's most likely at Crossfit or at home with her boyfriend and three dogs.</p></div><div class='node-author-email'>
        <a href='/user/352472/contact'>
          <span itemprop='email'>eleipholtz@echopress.com</span>
        </a>
        </div><div class='node-author-number'>(320) 763-1233</div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',17);
  ga('send', 'event', 'article', 'paragraphs', '17');
  ga('send', 'event', 'article', 'length', 'characters',1687);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',35539);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',17);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '17');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',1687);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',35539);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4323615-update-teen-girl-swam-escape-captors-three-men-arrested"><span class="number">1. </span>Update: Teen girl swam to escape captors; three men arrested</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured"><span class="number">2. </span>Updated: One airlifted after crash near Brandon, five others injured</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/4323835-mom-two-suspects-were-best-friends"><span class="number">3. </span>Mom: Two suspects were ‘best friends’</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/crime/4323036-updated-three-arrested-after-alexandria-teen-found-grant-county"><span class="number">4. </span>Updated: Three arrested after Alexandria teen found in Grant County</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4323836-mom-two-suspects-were-best-friends"><span class="number">5. </span>Mom: Two suspects were ‘best friends’</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4323860-b-e-board-will-rethink-school-plans">B-E board will rethink school plans<span class='latest-date'>8 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/4323836-mom-two-suspects-were-best-friends">Mom: Two suspects were ‘best friends’<span class='latest-date'>9 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/4323835-mom-two-suspects-were-best-friends">Mom: Two suspects were ‘best friends’<span class='latest-date'>9 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/4323823-updated-one-airlifted-after-crash-near-brandon-five-others-injured">Updated: One airlifted after crash near Brandon, five others injured<span class='latest-date'>9 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/opinion/columns/4322765-observations-archives-1967-major-league-scouts-eye-tournament">Observations from the Archives: 1967: Major league scouts eye tournament <span class='latest-date'>13 hours ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget odd block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='http://www.forumnewspaper.com/EchoPress/' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/echopress" title="">Subscribe to the Paper</a></li><li><a href="http://digital.olivesoftware.com/olive/odn/echopress/default.aspx" title="Access E-Paper">Access E-Paper</a></li>          </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="mailto:customerservice+echopress.com@forumcomm.com" title="">Get Website Help</a></li>
      <li><a href="http://www.forumcomm.com/careers/" title="">Work With Us</a></li>
    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://twitter.com/echopress" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/echopress" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Echo Press</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Echo Press</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">225 7th Ave E<br /> P.O. Box 549</div>
      <span class="locality">Alexandria</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">56308</span>
    </div>

    Call us at <div class="tel">320-763-3133</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"><span style="display: none;">randomness</span></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=echopress.com&tags=News,Brandon, Crash, Brandon First Responders, Brandon Fire Department, Douglas County Sheriff's Office,Life Link III,North Ambulance',
    type: 'GET',
    dataType: 'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?ovvuin"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?ovvuin"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?ovvuin"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?ovvuin"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>