<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Al Edenloff" />
<meta property="news_keywords" content="News,Lakes Area Crisis Response Team, firefighters" />
<meta property="description" content="Firefighters from throughout the region took to the catwalk Saturday night, all for a good cause -- the Lakes Area Crisis Response Team.They showed their dance..." />
<meta property="keywords" content="News,Lakes Area Crisis Response Team, firefighters" />
<meta property="article:publisher" content="https://www.facebook.com/echopress" />
<meta property="article:published_time" content="2017-01-08T16:00:27-06:00" />
<meta property="image:alt" content="Stephen VanLuik with the Forada Fire Department dances down the catwalk at the Firefighter&#039;s Runway Competition and Comedy Show at the Broadway Ballroom Saturday night. (Al Edenloff | Echo Press)" />
<meta property="article:modified_time" content="2017-01-08T16:00:27-06:00" />
<meta property="article:tag" content="News,Lakes Area Crisis Response Team, firefighters" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:image" content="http://www.echopress.com/sites/default/files/styles/16x9_430/public/field/image/DSC_7376_0.jpg?itok=aUErnnii" />
<meta property="fb:app_id" content="664199946964112" />
<meta property="twitter:url" content="http://www.echopress.com/news/4194843-firefighters-show-their-dance-moves" />
<meta property="twitter:title" content="Firefighters show their dance moves" />
<meta property="twitter:description" content="Firefighters from throughout the region took to the catwalk Saturday night, all for a good cause -- the Lakes Area Crisis Response Team.They showed their dance moves and interacted with the crowd at the Broadway Ballroom in Alexandria as part of the second annual Firefighter&#039;s Runway Competition and..." />
<meta property="og:type" content="article" />
<meta property="og:description" content="Firefighters from throughout the region took to the catwalk Saturday night, all for a good cause -- the Lakes Area Crisis Response Team.They showed their dance moves and interacted with the crowd at the Broadway Ballroom in Alexandria as part of the second annual Firefighter&#039;s Runway Competition and..." />
<meta property="og:url" content="http://www.echopress.com/news/4194843-firefighters-show-their-dance-moves" />
<meta property="og:image:width" content="300" />
<meta property="og:image" content="http://www.echopress.com/sites/default/files/styles/square_300/public/field/image/DSC_7376_0.jpg?itok=zz9-XTmU" />
<meta property="og:image:height" content="300" />
<meta property="og:title" content="Firefighters show their dance moves" />
<link rel="apple-touch-icon" href="http://www.echopress.com/sites/all/themes/echopress_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.echopress.com/sites/all/themes/echopress_theme/favicon.ico" type="image/x-icon" />
<link rel="amphtml" href="http://www.echopress.com/news/4194843-firefighters-show-their-dance-moves?amp" />
<link rel="shortlink" href="/node/4194843" />
<link rel="canonical" href="/news/4194843-firefighters-show-their-dance-moves" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>Firefighters show their dance moves | Echo Press</title>
    <link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/fcc_basetheme/css/article-slider.css?ojbpim" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?ojbpim" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/echopress_theme/css/global-no-mqs.css?ojbpim" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/all/themes/echopress_theme/css/global.css?ojbpim" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.echopress.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_27W8u-HbankbPYe4D1Wd0wx_MB32l4m4HZYxyDhiieo.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-6', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var site_latitude = 45.88426; var site_longitude = -95.3739779;
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_-dH1LpOA9AW_1o6V1h4CT90LzFwm7Vv_b-HudWfpTo8.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_weather/scripts/min/fcc_weather_map_control.min.js?ojbpim"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?ojbpim"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?ojbpim"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-EchoPress"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        var ybotq = ybotq || [];
        (function() {
        var js = document.createElement('script');
        js.src = '//cdn.yldbt.com/js/yieldbot.intent.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(js, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        function ybWidth(){
          var w = window,
              d = document,
              e = d.documentElement,
              x = Math.max(e.scrollWidth,e.offsetWidth,e.clientWidth);
          return x;
        }
        ybotq.push(function () {
          if(ybWidth()>=481) {
            yieldbot.pub('be77');//desktop
            yieldbot.defineSlot('LB');
            yieldbot.defineSlot('MR', {sizes: [
                [300, 250],
                [300, 600]
            ]});
            yieldbot.defineSlot('MR_2', {sizes: [
                [300, 250],
                [300, 600]
            ]});
          } else {
            yieldbot.pub('061f');//mobile
            yieldbot.defineSlot('MLB');
            yieldbot.defineSlot('mobrec');
          }
          yieldbot.enableAsync();
          yieldbot.go();
        });
//--><!]]>
</script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4194843 node-type-article domain-www-echopress-com context-news"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Echo Press"><img src="http://www.echopress.com/sites/all/themes/echopress_theme/logo.png" alt="Echo Press" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Echo Press</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/news/4194843-firefighters-show-their-dance-moves" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4194843-firefighters-show-their-dance-moves'>Firefighters show their dance moves</a></li><li><a href='/news/4193897-agweektv-worshiping-newborn-king'>AgweekTV: Worshiping the newborn king</a></li><li><a href='/news/4193947-sex-crimes-statute-limitations-varies'>In sex crimes, statute of limitations varies</a></li><li><a href='/news/4193782-readying-rinks'>Readying the rinks </a></li><li><a href='/news/4192919-alex-highs-footloose-earns-prestigious-award'>Alex high&#039;s &#039;Footloose&#039; earns prestigious award </a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/crime" target="_self">crime</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/state" target="_self">state</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/cardinals/4194807-mesabi-east-invite-rescheduled-jan-14'>Mesabi East Invite rescheduled for Jan. 14</a></li><li><a href='/sports/blizzard/4194806-blizzard-hockey-alex-sweeps-willmar-4-0-win-saturday'>Blizzard hockey: Alex sweeps Willmar with 4-0 win on Saturday</a></li><li><a href='/sports/cardinals/4194805-gymnastics-cards-bring-home-first-place-park-rapids-invite'>Gymnastics: Cards bring home first place from Park Rapids Invite</a></li><li><a href='/sports/cardinals/4194544-dance-alexandria-takes-second-kick-home-invitational-w-video'>Dance: Alexandria takes second in kick at home invitational (w/ video)</a></li><li><a href='/sports/4194482-sports-roundup-friday-jan-6'>Sports roundup from Friday, Jan. 6</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/cardinals" target="_self">cardinals</a></li><li><a href="/sports/chargers" target="_self">chargers</a></li><li><a href="/sports/silverstreaks" target="_self">silverstreaks</a></li><li><a href="/sports/arrows" target="_self">arrows</a></li><li><a href="/sports/blizzard" target="_self">blizzard</a></li><li><a href="/sports/area" target="_self">area</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/library/4192927-get-creative-library'>Get creative at the library</a></li><li><a href='/life/faith/4192924-faith-column-timeless-wisdom-new-year'>FAITH COLUMN: Timeless wisdom for the new year</a></li><li><a href='/life/faith/4192923-our-savioursfahlun-council-receives-seven-seals-award'>Our Saviour&#039;s/Fahlun Council receives Seven Seals Award</a></li><li><a href='/life/faith/4192893-tim-schiller-be-installed-good-shepherd'>Tim Schiller to be installed at Good Shepherd</a></li><li><a href='/life/events/4192935-two-births-ring-new-year-douglas-county-hospital'>Two births ring in the new year at Douglas County Hospital </a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/faith" target="_self">faith</a></li><li><a href="/life/features" target="_self">features</a></li><li><a href="/life/entertainment" target="_self">entertainment</a></li><li><a href="/life/events" target="_self">events</a></li><li><a href="/life/meeting-calendar" target="_self">meeting calendar</a></li><li><a href="/life/school" target="_self">school</a></li><li><a href="/life/senior" target="_self">senior</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/new-arrivals/4192930-births-jan-6-2017'>Births - Jan. 6, 2017</a></li><li><a href='/milestones/4193300-engaged-wood-and-netter'>Engaged - Wood and Netter</a></li><li><a href='/milestones/new-arrivals/4188833-births-dec-30-2016'>Births - Dec. 30, 2016</a></li><li><a href='/milestones/new-arrivals/4185150-births'>Births</a></li><li><a href='/milestones/new-arrivals/4180708-births-dec-16-2016'>Births - Dec. 16, 2016</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/weddings" target="_self">weddings</a></li><li><a href="/milestones/100-candles" target="_self">100 candles</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/new-arrivals" target="_self">new arrivals</a></li></ul></div></div></li><li class='leaf'><a href="/outdoors" target="_self">outdoors</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/outdoors/4191344-capturing-moment-hunt-down-your-photos-contest-winners'>Capturing the moment: Hunt Down Your Photos contest winners</a></li><li><a href='/outdoors/4191338-mike-frisch-find-those-mid-winter-crappies'>Mike Frisch: Find those mid-winter crappies</a></li><li><a href='/outdoors/4188962-dnr-release-third-case-cwd-deer-identified-southeastern-minnesota'>DNR release: Third case of CWD in deer identified in southeastern Minnesota </a></li><li><a href='/outdoors/4188137-morken-sitka-added-list-gear-i-love-hunt-after-season'>Morken: Sitka added to list of gear I love to hunt with after this season</a></li><li><a href='/outdoors/4186060-fishing-heats-temperatures'>Fishing heats up with the temperatures</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4194876-milford-o-auran'>Milford O. Auran</a></li><li><a href='/obituaries/4194822-francis-fran-wagner'>Francis &quot;Fran&quot; Wagner</a></li><li><a href='/obituaries/4193194-phyllis-j-hanak'>Phyllis J. Hanak</a></li><li><a href='/obituaries/4194180-tamara-tammie-j-amundsen-reignier'>Tamara &quot;Tammie&quot; J. Amundsen Reignier</a></li><li><a href='/obituaries/4193806-edward-j-morrison'>Edward J. Morrison</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/commentaries/4192888-commentary-our-system-has-no-guarantees'>COMMENTARY: Our system has no guarantees</a></li><li><a href='/opinion/letters/4192887-letter-bashers-are-real-sinners'>LETTER: Bashers are the real sinners</a></li><li><a href='/opinion/columns/4192885-its-our-turn-christmas-eve-surprise'>IT&#039;S OUR TURN: A Christmas Eve surprise </a></li><li><a href='/opinion/columns/4192883-thumbs-upthumbs-down'>Thumbs Up/Thumbs Down</a></li><li><a href='/opinion/editorials/4191542-editorial-killer-lurking-your-basement'>EDITORIAL: Is a killer lurking in your basement?</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/commentaries" target="_self">commentaries</a></li></ul></div></div></li><li class='leaf'><a href="/country" target="_self">country</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/country/farm/4191556-free-seminar-discusses-keeping-farm-family'>Free seminar discusses keeping the farm in the family</a></li><li><a href='/country/farm/4191555-beef-home-study-courses-offered-online'>Beef home study courses offered online</a></li><li><a href='/country/extension/4191554-winter-berries-add-pop-color-landscape'>Winter berries add pop of color to landscape</a></li><li><a href='/country/4191568-open-house-discuss-water-quality-certification'>Open house to discuss water quality certification</a></li><li><a href='/country/agriculture/4187471-state-board-seeks-comments-buffer-law-policies'>State board seeks comments on buffer law policies</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/country/4-h" target="_self">4 h</a></li><li><a href="/country/agriculture" target="_self">agriculture</a></li><li><a href="/country/extension" target="_self">extension</a></li><li><a href="/country/farm" target="_self">farm</a></li><li><a href="/country/gardening" target="_self">gardening</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">business</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/business/4192942-2017-alexandria-lakes-area-visitors-guide-now-available'>2017 Alexandria Lakes Area Visitors Guide is now available</a></li><li><a href='/business/4192921-stallman-named-wci-interim-president'>Stallman named WCI interim president</a></li><li><a href='/business/4188830-fresh-start-alex-tailoring'>A fresh start for Alex Tailoring </a></li><li><a href='/business/4185109-paul-davis-continues-longtime-service-new-owners'>Paul Davis continues longtime service with new owners</a></li><li><a href='/business/new-business/4185105-brewery-grand-opening-set-monday'>Brewery grand opening set for Monday</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/business/awards" target="_self">awards</a></li><li><a href="/business/hires-and-promotions" target="_self">hires and promotions</a></li><li><a href="/business/new-business" target="_self">new business</a></li><li><a href="/business/street" target="_self">On The Street</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="News "> <meta itemprop='dateline' content="Alexandria,Minnesota 56308"> <meta itemprop='articleBody' content="&lt;p&gt;Firefighters from throughout the region took to the catwalk Saturday night, all for a good cause -- the Lakes Area Crisis Response Team.&lt;/p&gt;&lt;p&gt;They showed their dance moves and interacted with the crowd at the Broadway Ballroom in Alexandria as part of the second annual Firefighter's Runway Competition and Comedy Show. Categories for the runway portion of the night include tight T-shirt, family, chiefs and officers, and bachelors.&lt;/p&gt;&lt;p&gt;The fundraiser helps the Lakes Area Crisis Response Team, a self-funded organization that offers stress mitigation and debriefing services to area emergency response agencies.&lt;/p&gt;&lt;p&gt;The team began two years ago and currently serves 11 fire departments in Douglas County, as well as agencies in Pope, Todd and Grant counties.&lt;/p&gt;&lt;p&gt;One of the main ways the crisis team aids area agencies is by holding debriefings after a traumatic event.&lt;/p&gt;&lt;p&gt;&quot;Basically what we do is we go in when there's been a bad call and we work with the officers or firefighters to make sure that they don't get left behind or fall through the cracks,&quot; said Jeff Tacker, the president of the team. &quot;Rural America really suffers. One of the top 10 traumas is knowing your own victim, and just about every person in rural America who serves as a first responder or firefighter knows their victims.&quot;&lt;/p&gt;&lt;p&gt;Tacker says he often observes people ignoring their emotions after such an event, which can build and build over time.&lt;/p&gt;&lt;p&gt;&quot;I call it stuffing,&quot; he said. &quot;The way I explain it in a meeting is that it's like putting garbage in a trash can and not emptying it. You just keep pushing it down. And eventually you realize it needs to come out but it won't because it's so much garbage in there. We sometimes do that with our emotions and then we have a bigger problem.&quot;&lt;/p&gt;&lt;p&gt;The team is completely self-funded and volunteer based. At any point, donations may be sent to the Lakes Area Crisis Response Team at P.O. box 571, Alexandria.&lt;p&gt;&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;For more information, contact Jeff Tacker at tackerjd@gmail.com or (320) 304-0231. The benefit was sponsored by Fat Daddys, Budweiser and the Hampton Inn.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Firefighters show their dance moves"> <meta itemprop='author' content="Al Edenloff"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.echopress.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-01-08T16:00:27"> <meta itemprop='dateModified' content="2017-01-08T16:00:27"> <link itemprop='mainEntityOfPage' content="node/4194843"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.echopress.com/sites/default/files/styles/square_300/public/field/image/DSC_7376_0.jpg?itok=zz9-XTmU"> <meta itemprop="width" content="6000"> <meta itemprop="height" content="4000"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Al Edenloff"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="Echo Press"</span> <meta itemprop="name" content="Al Edenloff"> <meta itemprop="homeLocation" content="Alexandria"> <div itemprop='contactPoint' itemscope itemtype='http://schema.org/ContactPoint'> <meta itemprop='faxNumber' content="(320) 763-3258"> <meta itemprop='contactType' content="customer support"> <meta itemprop='url' content="http://www.echopress.com"> <meta itemprop='telephone' content="(320) 763-1236"> <meta itemprop='email' content="AEdenloff@echopress.com"> </div> <meta itemprop='url' content="http://www.echopress.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Firefighters show their dance moves "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Alexandria"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="225 7th Ave E<br /> P.O. Box 549"> <meta itemprop='postalCode' content="56308"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        });
        </script>
        </div><h1 class='node-title'>Firefighters show their dance moves</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/al-edenloff'>Al Edenloff</a></span>
  <span class='node-byline-time'> Today  at 4:00 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large'><div style='position: relative;'><img class='node-image large' src='http://www.echopress.com/sites/default/files/styles/16x9_620/public/field/image/DSC_7376_0.jpg?itok=igk0SveJ' data-featherlight='http://www.echopress.com/sites/default/files/styles/full_1000/public/field/image/DSC_7376_0.jpg?itok=-stuWFps'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Stephen VanLuik with the Forada Fire Department dances down the catwalk at the Firefighter&#039;s Runway Competition and Comedy Show at the Broadway Ballroom Saturday night. (Al Edenloff | Echo Press)</span></div></div><style>.page-node div.article-slider ul li {display:block;} img.image-info {float: none; display: none !important;} div span.image-caption {display: inline-block; width: 100%;}</style><div class='node-body'><p>Firefighters from throughout the region took to the catwalk Saturday night, all for a good cause -- the Lakes Area Crisis Response Team.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_wiisnbtdswy757ucga6y5y6zkq' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>They showed their dance moves and interacted with the crowd at the Broadway Ballroom in Alexandria as part of the second annual Firefighter's Runway Competition and Comedy Show. Categories for the runway portion of the night include tight T-shirt, family, chiefs and officers, and bachelors.</p><p>The fundraiser helps the Lakes Area Crisis Response Team, a self-funded organization that offers stress mitigation and debriefing services to area emergency response agencies.</p><p>The team began two years ago and currently serves 11 fire departments in Douglas County, as well as agencies in Pope, Todd and Grant counties.<div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div></p><p>One of the main ways the crisis team aids area agencies is by holding debriefings after a traumatic event.</p><p>"Basically what we do is we go in when there's been a bad call and we work with the officers or firefighters to make sure that they don't get left behind or fall through the cracks," said Jeff Tacker, the president of the team. "Rural America really suffers. One of the top 10 traumas is knowing your own victim, and just about every person in rural America who serves as a first responder or firefighter knows their victims."</p><p>Tacker says he often observes people ignoring their emotions after such an event, which can build and build over time.</p><p>"I call it stuffing," he said. "The way I explain it in a meeting is that it's like putting garbage in a trash can and not emptying it. You just keep pushing it down. And eventually you realize it needs to come out but it won't because it's so much garbage in there. We sometimes do that with our emotions and then we have a bigger problem."</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>The team is completely self-funded and volunteer based. At any point, donations may be sent to the Lakes Area Crisis Response Team at P.O. box 571, Alexandria.</p><p class="subhead">For more information, contact Jeff Tacker at <a href="mailto:tackerjd@gmail.com">tackerjd@gmail.com</a> or (320) 304-0231. The benefit was sponsored by Fat Daddys, Budweiser and the Hampton Inn.</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.echopress.com/taxonomy/term/1'>News</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/291154'>Lakes Area Crisis Response Team</a><a class='topic tag' href='http://www.echopress.com/taxonomy/term/7487'>firefighters</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/al-edenloff'>Al Edenloff</a><div class='node-author-bio'>Al Edenloff is the news and opinion page editor for the Echo Press. He was born in Alexandria and lived most of his childhood in Parkers Prairie. He graduated with honors from Moorhead State University with a degree in mass communications, print journalism. He interned at the Echo Press in the summer of 1983 and was hired a year later as a sports reporter. He also worked as a news reporter/photographer. Al is a four-time winner of the Minnesota Newspaper Association's Herman Roe Award, which honors excellence in editorial writing.

&nbsp;</div><div class='node-author-email'>
        <a href='/user/207547/contact'>
          <span itemprop='email'>AEdenloff@echopress.com</span>
        </a>
        </div><div class='node-author-number'>(320) 763-1236</div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',13);
  ga('send', 'event', 'article', 'paragraphs', '13');
  ga('send', 'event', 'article', 'length', 'characters',2174);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',9328);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',13);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '13');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',2174);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',9328);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4194843-firefighters-show-their-dance-moves"><span class="number">1. </span>Firefighters show their dance moves</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/4192997-alex-native-usa-cyclist-missy-erickson-goes-public-sexual-abuse-she-says-started-age-17"><span class="number">2. </span>Alex native, USA cyclist Missy Erickson goes public with sexual abuse she says started at age 17</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4194822-francis-fran-wagner"><span class="number">3. </span>Francis &quot;Fran&quot; Wagner</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/cardinals/4194544-dance-alexandria-takes-second-kick-home-invitational-w-video"><span class="number">4. </span>Dance: Alexandria takes second in kick at home invitational (w/ video)</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4194180-tamara-tammie-j-amundsen-reignier"><span class="number">5. </span>Tamara &quot;Tammie&quot; J. Amundsen Reignier</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4194843-firefighters-show-their-dance-moves">Firefighters show their dance moves<span class='latest-date'>2 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/cardinals/4194807-mesabi-east-invite-rescheduled-jan-14">Mesabi East Invite rescheduled for Jan. 14<span class='latest-date'>7 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/blizzard/4194806-blizzard-hockey-alex-sweeps-willmar-4-0-win-saturday">Blizzard hockey: Alex sweeps Willmar with 4-0 win on Saturday<span class='latest-date'>7 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/cardinals/4194805-gymnastics-cards-bring-home-first-place-park-rapids-invite">Gymnastics: Cards bring home first place from Park Rapids Invite<span class='latest-date'>7 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/cardinals/4194544-dance-alexandria-takes-second-kick-home-invitational-w-video">Dance: Alexandria takes second in kick at home invitational (w/ video)<span class='latest-date'>1 day ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget odd block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget even block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='http://www.forumnewspaper.com/EchoPress/' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/echopress" title="">Subscribe to the Paper</a></li>      <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
          </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://twitter.com/echopress" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/echopress" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Echo Press</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Echo Press</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">225 7th Ave E<br /> P.O. Box 549</div>
      <span class="locality">Alexandria</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">56308</span>
    </div>

    Call us at <div class="tel">320-763-3133</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"><!-- randomness --></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/modules/custom/fcc_advertising/adblock/min/adblock.min.js?ojbpim"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=echopress.com&tags=News,Lakes Area Crisis Response Team, firefighters',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?ojbpim"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?ojbpim"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_G8mSPrDqUT0jvAeB6lhOR3XaxjEZITO9rCPei8bVAos.js"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?ojbpim"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.echopress.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?ojbpim"></script>
<script type="text/javascript" src="http://www.echopress.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        });
        </script>
        </div>  </body>
</html>